How to Fix VMWare Player Error on Ubuntu 15.04 Vivid

Published by: Emil // Date 8.5.2015 // Views: 4264 // Add to Twitter :: Facebook

Image
Well, there is no fix, are just some discussions about some way to fix with patches from pastie.org but that thing doesn't work on 32 Bit machine because of new Linux Kernel 3.19 probably. It may work maybe on 64 bit machine using last VMware Player 7.1.0 ( VMware-Player-7.1.0.x86_64.bundle.tar )


The only thing remained to be made is to remove the VMWare Player and to import the VMDK ( Virtual Machine Disk ) from VMWare Player into VirtualBox :)


Not every VMDK will work, Ubuntu VMDK works fine , even the old 10.04 LTS. Windows7 works also fine, only the Windows Xp is crashing.




########################
##
## REMOVE VMPLAYER
##
########################

sudo vmware-installer -u vmware-player
sudo vmware-installer -u vmware-workstation



-----------------------

Related:

How to Install VMware Player 7.1.0 in Ubuntu/Linux Mint
http://www.upubuntu.com/2015/02/how-to-install-vmware-player-710-in.html

VMWare Images in VirtualBox importieren / konvertieren
http://bytelude.de/2011/10/20/quicktip-vmware-images-in-virtualbox-importieren-konvertieren/

Discussions about patching vmnet.tar file:
https://wiki.archlinux.org/index.php/VMware#3.19_kernels_and_up
https://fedoraproject.org/wiki/VMWare#On_3.17_kernel_vmnet_fails_to_build
https://forum.ubuntu-tr.net/index.php?topic=47323.0
https://wiki.archlinux.org/index.php/VMware
http://askubuntu.com/questions/614525/15-04-vmware-player
http://askubuntu.com/questions/414783/unable-to-run-vmware-failed-to-build-vmnet